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[bookmark: _Toc188245051][bookmark: _toc1260]Introduction
Along the Galaxy project extensive research was carried out centred on the scalability problem when using large numbers, big sized and heterogeneous models with complex interrelations, and on how to best provide solutions to it. The results of this research work have been described in D.3.1.2 in terms of a Domain Specific Language architecture called MoScript. As a next step, this architecture has been materialized in a prototype, which serves as proof of concept for the research and whose description is the main purpose of this document. 

The developed prototype has been conceived as a complement for the AtlanMod MegaModel Management (AM3) prototype, which is part of the Modisco MDT project and has been committed to eclipse.
 
[bookmark: _toc1264]This document describes the MoScript prototype. It explains the role the different plug-ins play in the language, its installation process and describes the concrete syntax of the language.
[bookmark: _Toc188245052]INSTALLation process
The MoScript prototype is available from the Eclipse-MDT MoDisco SVN [footnoteRef:1](sources only). The steps to install MoScript are the following: [1:  http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/indigosr1] 


· Download the Eclipse Modeling Tools from here: Eclipse Modeling Tools (Indigo)
· Install ATL from sources:
· Download the ATL source code project set file (.psf) from here [1].
· Import it into Eclipse with File->Import->Team->Team Project Set.
· Download the MoScript patch for ATL from Bugzilla – Bug 361688.
· Click right click on any ATL plugin project and select Team->Apply Patch ... and select the patch to apply it to ATL.
· Install subclipse and subversion if you have not done it yet.
· Install AM3 and MoScript from sources:
· Open the SVN perspective by selecting Window -> Open Perspective-> SVN Repository Exploring perspective.
· Add a new repository location by selecting File->New->Repository Location. The required parameters are the followings:
· Url: https://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.modisco/incubation/trunk/am3
· User: anonymous
· Browse the just created repository location until /plugins/trunk and checkout all the plugins



[bookmark: _Toc188245053]Prototype Architecture
This section presents the concrete architecture of the prototype. It describes the internal structure of the prototype in terms of plug-ins, details its core metamodel and explains the extension mechanism provided. As mentioned in deliverable D3.2 (Megamodel for Transformations Architecture), MoScript depends on AM3 and ATL eclipse plugins as shown in Figure 1.

[image: :::::::Desktop:MoScriptArchitecture.jpg]
[bookmark: _Ref186635815]Figure 1 MoScript dependencies

[bookmark: _Toc188245054]Plug-ins
As an Eclipse component, the prototype is implemented by a set of Eclipse plugins, each of them having a specific role. Figure 2 shows the MoScript components and their dependencies.  

 

· org.eclipse.am3.common: Contains the MoScript abstract syntax in the form of an Ecore metamodel and provides means for retrieving the resource.
· org.eclipse.am3.moscript.engine: Contains the MoScript to ATL binary code compiler.
· org.eclipse.am3.moscript.dsls: Contains the MoScript parser and lexer classes
· org.eclipse.am3.moscript.core.emf: Contains the EMF factory for instantiating the MoScript EMF based engine.
· org.eclipse.am3.moscript.ui: Contains the classes related with MoScript project creation wizard, nature and builder.
· org.eclipse.am3.moscript.launch: Contains the classes related to the launcher of MoScript scripts.
· org.eclipse.am3.moscript.atl.ext: Contains the classes which extend the ATL OCL engine with custom side effects free operations. 

[image: :::::::Desktop:MoScript components.jpg]



[bookmark: _Toc188245055]moscript Language
MoScript reuses a big part of the ATL syntax and semantics such as the OCL expressions and data types, the control flow statements and the helpers. Any doubt about MoScript may be usually solved imitating the ATL syntax. MoScript syntax specifics will be explained next.

[bookmark: _Toc188245056]Language general structure
A MoScript program has the following general structure:

program program_name  

uses library ...   

[using {
  -- Comments
  ...
  -- Variable declarations  
  variable :type = OclExpr ... 
}]  

do { 
  -- Value assignements 
  variable <− OclExpr;  

  -- Operations invocations 
  ... save(...);  
  ... remove(OclExpr);   
  ... register (...);  

  -- Control flow statements    
  if...    
  for... 
}  

helper context OclAny def: helper_name( params ) :return_type 
  ...  
; 

The using section is optional, and is used for declaring variables and assigning their initial value. The do section is mandatory and is the core of the program. In it, operations are used in combination with control flow statements and OCL queries to perform modelling artefacts manipulations.

[bookmark: _Toc188245057]Model element data type
The OCL specification introduces de model element data type. This type corresponds to the classes contained in the metamodel of the model is being queried. In the case of MoScript, the model which is being queried, is a megamodel, so the model elements allowed in MoScript correspond to classes of the metamodel of the megamodel. MoScript uses the implementation of the megamodel provided by AM3 which conforms to the following metamodels among others:

· AM3Core: Is the top hierachy metamodel and can be found in /org.eclipse.gmt.am3.platform.runtime.core/model/AM3Core.ecore
· GMM: Which extends AM3Core and can be found in/org.eclipse.gmt.am3.platform.extension.globalmodelmanagement/model/GlobalModelManagement.ecore
· GMM4ATL: A megamodel extension specific for ATL M2M transformations, which extends AM3Core and GMM and can be found in/org.eclipse.gmt.am3.platform.extension.gmm4atl/model/GMM4ATL.ecore 

Model element variables are referred to by means of the notation !Class. For instance, !Model, !TerminalModel, !ATLTransformation etc.

[bookmark: _Toc188245058]Operations
Model :: allContentInstancesOf(elementType :String): Collection(OclAny)

This operation dereferences and load the physical model represented by the Model element. Then it queries the model and return a collection of OCL elements of type elementType. The elements of the resulting collection are used as entry points to the model, from where the rest of the elements may be reached. Subsequent queries to the model content are made with standard OCL expressions.

Model :: inject(injectorName: String, modelElement: TupleType(...)) : Model

This operation make a projection of model expressed in a textual syntax to a model in XMI conforming to a given metamodel. injectorName is the name of the injector that is going to be used to make the projection of the model and modelElement represents the metadata information that will describe the new model. The structure of the tuple is explained along with the register operation.

Model :: save(location :String)

This operation stores the model in location
    
ATLTransformation :: applyTo(Map{(key :String, model :Model),
                             ...,(..., ...)}) :Map(key :String, model :Model)

This operation applies the a transformation to one or more models. The key is the alias of that identifies the model inside an ATL transformation module and model is a model obtained from the megamodel.
register(TupleType(concreteType :String, value :Set(TupleType(...))))

This operation does the registration of a model in the megamodel i.e. it creates a new element in the megamodel of type concreteType where:
· concreteType: Is a string with the concrete type of the model element to be created. The string must be in the form ofPackage::ConcreteType. For instance GlobalModelManagement::URI, GlobalModelManagement::ReferenceModel etc.
· value: Corresponds to a set of attributes and references of the model element, each of them described again by a tuple as follows:
· 
· Attribute tuple:

TupleType(attributeName :String, primitiveType :String, attributeValue :String)

· Reference tuple:

TupleType(creationId :String, referenceName :String, concreteType :String,              
          referenceValue :Set(TupleType(...)))

TupleType(referenceName: String, concreteType :String, creationId: String)

There are two ways for declaring reference tuples. The first one creates the element to be referenced and then references it, the second one asumes that the elements have been already created (in the same register operation), thus it uses the creationId of the element to be referenced to find it and reference it. 

The creationId is just a kind name that must be given to a model element instance when it is created, if we want it to be referenced by another élément in the same register operation. Otherwise it is not mandatory.

Note that the Tuples are used as a recursive way of expressing the creation of model elements, the model elements referenced by this elements and so on, and also the attributes contained in each model element.

IdentifiedElement :: remove()

This operation allows removing any megamodel element, which extends from the Core::IdentifiedElement element.

ReferenceModel :: registerInEMFpkgReg()

This operation registers the reference model in the EMF packages registry

collectWrkSpaceFileNames() :Collection(String)

The collectWrkSpaceFileNames operation queries the eclipse workspace to get all the workspace filenames.

[bookmark: _Toc188245059]Examples
The followings are a set of examples that demonstrate the use of some of the operations. Select all the models in the megamodel, get the first one and get a collection of all its elements of type EClass.

!Model.allInstances()->first().allContentInstancesOf('EClass');

Select all the models in the megamodel, get the first one and remove it from the megamodel.

!Model.allInstances()->first().remove(); 

Select the models in textual syntax, which conform to a given xmlRefernceModel (grammar), get the first one and then inject it with the XML injector to obtain an XML model in XMI format conforming to an XML metamodel. The xmlEcoreModelTuple contains the metadata information for the creation of the new model element like, identifier, locator, referenceModel etc.

xml <- !TerminalModel.allInstances()->select(m | m.conformsTo = xmlReferenceModel)
                                    ->first(); 
xmlModel <- xml.inject('XML', xmlEcoreModelTuple); 
[bookmark: Screencasts_.26_slides]
[bookmark: _Toc188245060]MoScript Hello World!
Create a new MoScript project by clicking on File-> New-> Project and selecting the MoScript project type under the AM3 Folder.
[image: mage:MoScript-HelloWorld2.png]
Then create a MoScript script by clicking in File-> New-> File. Give it the name helloWorld.mscr. When the file is open, fill it with the following script code:

program helloWorld  

do{  
  'HelloWorld'.debug(); 
} 

After saving the file, if there are no errors, you should see a new binary file called helloWorld.asm in the project explorer or navigator.

Now that the code is ready, create a MoScript launcher to run the script, by clicking in 

Run-> Run Configurations... 
[image: mage:MoScript-HelloWorld3.png]

Browse in the workspace for the HelloWorld.mscr file and select it. Then, in the advanced tab, check the options Clear console before launch and Print execution times to console, so that you can clearly see when de script finishes.
[image: mage:MoScript-HelloWorld4.png]
Then press the Apply button and the Run button. In the console window you will see an error like the following:

Error loading file:...workspacePath/.am3/megamodel.xmi: java.io.FileNotFoundException: ... (No such file or directory) 

This is because the megamodel file has not been created yet. For creating the megamodel file, open the AM3 Perspective.
[image: mage:MoScript-HelloWorld1.png]

Create any model element in the megamodel left clicking in any element in the left panel, selecting new [element]. Give any value to the element and then use File->Save option to save the Megamodel. With this operation the Megamodel file is created in the filesystem.

[image: mage:MoScript-HelloWorld5.png]

Now try again to run the script by clicking on Run->Run History->Hello World and you should see the output in the console. 
[image: mage:MoScript-HelloWorld6.png]
[bookmark: The_MoScript_Language]



image6.jpeg
.

,

.
+ ccuses>





image7.jpeg
<o 8]

org.eclipse.am3 moscriptui

[ ~depends—>

<o B

org.eclipse.am3.moscriptatlext

<o B]

org.eclipse.am3.moscript.common

‘
|
-
‘

N
|

deperfency

4 :
D—
‘org.eclipseam3.moscriptengine (< — ~depends— — o

<<comones 8]

org.eclipse.am3.moscript core.emf

~
|
|
depands
I

s A

org.eclipse.am3.moscriptengine aunch

<<campames 8]

org.eclipse.am3 moscriptdsls





image8.png
= Eclipse Modeling Framework
= Graphical Modeling Framework
¥ = Examples
¥ (= Eclipse Modeling Framework.
1§ Extended Library Model Example

1§ Java Model Example
1§ Model Exporter Example





image9.png
000

Run Configurations

Create, manage, and run confgurations
@ piease give a oscrp e name

[CEx[e%:
CT—

© At Transtormation
© clipse Applcation
eva Appler

s Applcaton

e JET Transformation
Jomi

Tt Pog-in Test

3 Operations VT inerreser
% 05 Framework

i Task Contet Plug-in st
T Task Contet Test

Fiter mtched 14 of 14 tems.

Name: TMoscrip Helo Word

© Adarced| 5 Common]

@





image10.png
Create, manage, and run configurations @

REEIEES

ype filter text

© ATL Transformation
@ Eclipse Application
i java Applet
[lJava Application
% JET Transformation
Jujunie
3% Junit Plug-in Test
@ Moscript script

@ New_configuration
[B]MWE Woridiow
[3 Operational QUT Interp)
@ 05Gi Framework
JEiTask Context Plug-in T|
JuyTask Context Test

————RAlE

Fiter matched 14 of 14 ftems|

Name: [Moscript Hello World

@ woscript configuration (€ Advanced,, = Common|

Superimposed modules.

Superimposed modules.

Advanced parameters

-

@ set generated files as derived
(@ciar console before aunch

) Output model content types detection

O support UML2 stereotypes application
(&print execution times to console.

0] Allow inter-model references

() Print execution information to console for each executed bytecode (very verbosel)

== ===

@

E/





image11.png
New Window -
New Editor ol
B3Cs Repository Exploring

pective D £ CVs Repository Exploring

A outline i ot avalable.

‘Show View > &

Customize Perspective... | ¢ Java Browsing
Save Perspective As... £ Team Synchronizing
X XML

Close Al Perspectives.

Hgation) |50 Team Synchronizing
Toon

(G Tasks 58
O iems.

=

escripion

0 items selected

] B




image12.png
@&
£3 © . [ @S gt Qo pesoue

Beo k=0

B reomotamcs (@ Mesamose cor &

1 GlobalModelManagement:EPackagesRegistry
enter

pe [CobaNoG MR O

sounceor





image13.png
I HE]3%0-Qr @& @[] 8- e
5| € ATL @ AM3 Megamodeling (7 Resource
[ Project Explorer 23 = B[ helloworld.mscr 52

% progran hellaforld

CYehdioWord | gop
helloWorld.asm "HelloNorld" .debug(' '3
3

[2. Problems [ console ¢ @) Error Log|
ATL

“Hellolor1d"

hellofiorld executed in 0,001s.

An outline is not available.





image1.jpeg
0@

Galax

o
v




image2.jpeg




image3.png




image4.wmf

image5.png
AGENCE NATIONALE DE LA RECHERCHE





- Megamods! for Transformations prototype.
MoScrpt - Models Scrping Languag




